Firefox: Instalar un Add-on NO compatible

Si tenéis «versionitis» con firefox como lo tengo yo, os pasará que algunos «Add-on«-s no son compatibles con la versión. Eso no significa que no funcionen. Usaremos como ejemplo firebug.

Para empezar instalamos los paquetes necesarios:

su
aptitude install zip unzip
exit

Empezamos:

cd /tmp
wget http://getfirebug.com/releases/firebug/1.8/firebug-1.8.0.xpi
mv firebug-1.8.0.xpi firebug.zip
mkdir firebug
unzip firebug.zip -d firebug
nano firebug/install.rdf 

Buscamos dentro del siguiente apartado:


El siguiente tag y cambiamos el valor a nuestra versión actual de firefox:

6.*

Guardamos y seguimos en la consola:

cd firebug
zip firebug-new.zip -r *
mv firebug-new.zip firebug-new.xpi
mv firebug-new.xpi ../
cd ..

Ahora abrimos el firefox: Archivo -> Abrir fichero -> firebug-new.xpi

This entry was posted in Gnu / Linux, Internet, Tutoriales / Manuales and tagged , , , , . Bookmark the permalink.

Deja un comentario

Tu dirección de correo electrónico no será publicada.

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.